Results 1 to 4 of 4

  Click here to go to the first staff post in this thread.   Thread: Payment problem

  1. #1
    Apprentice iptables's Avatar
    Join Date
    Dec 2018
    Posts
    271

    Payment problem

    Right, so 2 weeks ago I bought a google play gift card, redeemed the code, bought what I wanted to buy and it was just as it should be.
    Today, the case is absolute nonsence....
    Bought a google play gift card ( yes from the same place and in the same country ), redeemed the code, I have my balance, BUT TOP11 tells me : Can't use this google play gift card from different country.
    Wut ?!? I take your pardon, could you repeat that again...
    Nordeus ?
    P.S. The first purchase was made BEFORE the update ( summer event ).
    Contact me via e-mail for more details : ID, screenshots and everything else.
    If you don't want my money, that's fine, I can spend them somewhere else.
    !!! And From The Ashes He Was Reborn !!!

  2.   This is the last staff post in this thread.   #2
    Administrator
    Join Date
    Jul 2020
    Posts
    140
    Hi iptables,

    Sorry to hear about the inconvenience. Please get in touch with support through the "?" in game or this form here. They'll be able to advise further.

    Best,
    Taliyah25

  3. #3
    Apprentice iptables's Avatar
    Join Date
    Dec 2018
    Posts
    271
    Greetings Taliyah, and thank you for the response.
    I've already tried with the "?" - result none. Meaning no answer.
    That's the reason I'm writing now in the forum, as a last try.
    P.S. Found an article that stands other people around the globe are having the exact same issue as me.
    According to that read, google messed up something somewhere, it seems, if the article is to be trusted.
    Again, just in case, I'd like an investigation of my case, providing all the information needed from my side.

    Thank you in advance.

    Regards : Martin
    Alaska SC

  4. #4
    Apprentice iptables's Avatar
    Join Date
    Dec 2018
    Posts
    271
    UPDATE :

    Greetings.
    Last night ( 30.06.2021 ) I did a factory reset on my device, and 30 minutes later I tried to use my balance in Google Play again, to buy certain offer in T11... without success...
    Today, when I made my morning coffee, read the news and all the regular daily stuff, decided to check my team, do some daily training... and guess what happened ?
    The "Mourinho's magical fingers" touched my shoulder... transaction success !
    No explanation can be provided, as I did nothing new from the last night's try.
    I can't explain how and why... it just worked today.
    If, by any reason, someone of the devs was in my account during that time, and fixed the problem, then I'd like to thank you for the support.
    Case closed, and I hope no future topics of this kind will occur